Mac OS X - Apple's Unix with a pretty face

Installing macOS High Sierra on a MacBook Pro or other Mac that is not supported by High Sierra

(April 12, 2018)

Apple has declared certain older Mac computers unsupported by newer versions of macOS. In my case, I attempted to install macOS High Sierra on a mid-2009 MacBook Pro, but the installer failed in a very strange way. I constructed a USB installer using the normal process to make a macOS installer, then rebooted the computer to run the installation, but instead the screen simply went blank and the computer turned itself off. In other words installing macOS High Sierra on this mid-2009 MacBook Pro failed in a strange way. After a couple dozen macOS installs on different computers under my belt, I'd never seen this behavior. After some duckduckgoing the cause was found to be this screen capture - that the computer was not supported by High Sierra - and fortunately there was a relatively simple solution.

Installing MacOSX when the installer says: OS X could not be installed on your computer. No packages were eligible for install.

(2016-10-16 15:41)

A key step for upgrading the disk on a MacBook Pro is to install a new operating system on the new drive, and then use Migration Assistant to copy over the old data. Depending on how you went about the work, installing Mac OS X on the new system may give you a message: OS X could not be installed on your computer. No packages were eligible for install.

This is what it looks like in the installer. Upon seeing this I went "HUH?" because the installation was from a thumb drive I'd used many times to install Mac OS X (El Capitan) successfully.